FailuresAccessorIsFailureResolutionPermitted(FailureMessageAccessor, FailureResolutionType) Method

Checks if resolution of the failure using given resolution type is permitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsFailureResolutionPermitted(
	FailureMessageAccessor failure,
	FailureResolutionType resolutionType
)

Parameters

failure  FailureMessageAccessor
Accessor to the failure to be resolved.
resolutionType  FailureResolutionType
Type of the failure resolution to be used.

Return Value

Boolean
True if resolution of the failure using given resolution type is permitted.
Exceptions
ExceptionCondition
ArgumentException failure has not been properly initialized.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException This FailuresAccessor is inactive (is used outside of failures processing).
See Also