RebarConstraintIsReferenceValidForConstraint Method |
Checks if the reference provided can be used in creating Rebar constraints
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsReferenceValidForConstraint(
Reference targetReference
)
Public Function IsReferenceValidForConstraint (
targetReference As Reference
) As Boolean
public:
bool IsReferenceValidForConstraint(
Reference^ targetReference
)
member IsReferenceValidForConstraint :
targetReference : Reference -> bool
Parameters
- targetReference Reference
-
The reference to be checked
Return Value
Boolean
returns true if reference can be used in a constraint, false otherwise
Exceptions
Remarks
Reference is valid if it points to an uncut face of a structural that can host rebar.
See Also