DrawContextIsAvailable Method |
Checks whether the facilities of this class are available for use in the current scope.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsAvailable()
Public Shared Function IsAvailable As Boolean
public:
static bool IsAvailable()
static member IsAvailable : unit -> bool
Return Value
Boolean
True if the DrawContext is available for rendering, false otherwise.
RemarksThis class can perform drawing operations and access the state of parameters related to drawing only
in lock-step with rendering inside of Revit. As a consequence, the facilities of this class are not available for
use outside of the scope determined by the callback RenderScene(View, DisplayStyle).
Certain methods of other DirectContext3D objects, e.g., VertexBuffer::Map() are similarly restricted by the same scope.
See Also