ViewShowActiveWorkPlane Method |
Show the active work plane of the view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void ShowActiveWorkPlane()
Public Sub ShowActiveWorkPlane
public:
void ShowActiveWorkPlane()
member ShowActiveWorkPlane : unit -> unit
ExceptionsException | Condition |
---|
InvalidOperationException | Thrown when there is no active sketch plane, or when an error occurs during setting the sketch plane visibility. |
RemarksIf this method is invoked while the current work plane is hidden, only the outline of the updated work plane will be shown immediately.
The updated sketch plane will be shown fully after the current transaction is committed. Therefore it is recommended the Add-On commits the transaction
before performing UI operations (for example, PickPoint).
See Also