ViewDisplayBackgroundImageFlags Enumeration |
A collection of bit flags that control how the background image is positioned
in relation to the crop region (or the view boundary).
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum ViewDisplayBackgroundImageFlags
Public Enumeration ViewDisplayBackgroundImageFlags
public enum class ViewDisplayBackgroundImageFlags
type ViewDisplayBackgroundImageFlags
MembersMember name | Value | Description |
---|
None | 0 |
The image is displayed pixel-to-pixel
|
FitToScreen | 1 |
The image is stretched in both directions
|
FixedAspectRatio | 2 |
The image is stretched but the ratio of its height to width is preserved.
|
UseTiling | 4 |
The pixels of the background are filled by tiling of the image.
|
See Also