RevitLinkGraphicsSettingsSetDiscipline Method

Sets discipline and discipline type of RevitLinkGraphicsSettings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetDiscipline(
	LinkVisibility disciplineType,
	ViewDiscipline discipline
)

Parameters

disciplineType  LinkVisibility
The type of the discipline.
discipline  ViewDiscipline
The discipline. If disciplineType is set to ByHostView or ByLinkView the discipline must be set to Architectural.
Exceptions
ExceptionCondition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also