SolidGetBoundingBox Method |
Retrieves a box that circumscribes the solid geometry.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic BoundingBoxXYZ GetBoundingBox()
Public Function GetBoundingBox As BoundingBoxXYZ
public:
BoundingBoxXYZ^ GetBoundingBox()
member GetBoundingBox : unit -> BoundingBoxXYZ
Return Value
BoundingBoxXYZ
Remarks
The bounding box information is stored as bounds in local coordinates and a transform.
So the transform is to be taken in to account when using the bounds.
This is different from the bounding box returned by Element.BoundingBox in that the bounding box
returned by that routine stores the bounds in modeling coordinates with an identity transform.
See Also