EnergyAnalysisDetailModelCreate Method |
Creates a new energy analysis detailed model.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static EnergyAnalysisDetailModel Create(
Document document,
EnergyAnalysisDetailModelOptions options
)
Public Shared Function Create (
document As Document,
options As EnergyAnalysisDetailModelOptions
) As EnergyAnalysisDetailModel
public:
static EnergyAnalysisDetailModel^ Create(
Document^ document,
EnergyAnalysisDetailModelOptions^ options
)
static member Create :
document : Document *
options : EnergyAnalysisDetailModelOptions -> EnergyAnalysisDetailModel
Parameters
- document Document
-
The document that contains the physical model of the building.
- options EnergyAnalysisDetailModelOptions
-
The options to control the calculation rules.
Return Value
EnergyAnalysisDetailModel
The created model instance.
ExceptionsException | Condition |
---|
ArgumentException |
An EnergyAnalysisDetailModel cannot be created if EnergyModelType.BuildingElement is input
and AnalysisMode.ConceptualMasses is set in EnergyDataSettings (these values are incompatible).
-or-
Throws if there are no valid spatial bounding elements,
or no valid spatial elements in the document.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
Failed to create the energy analysis detail model.
|
OperationCanceledException |
Throws if user aborted the energy analysis detail model creation.
|
Remarks
The generated energy model is always returned in world coordinates.
The method TransformModel() transforms all surfaces in the model according to
ground plane, shared coordinates and true north.
The EnergyModelType in argument EnergyAnalysisDetailModelOptions indicates
whether the generated energy model is based on rooms/spaces or building elements. The default value
is EnergyModelType.SpatialElement.
See Also