AssetPropertyListSetValue Method

Sets collection of properties stored in this property list.

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetValue(
	IList<AssetProperty> value
)

Parameters

value  IListAssetProperty
An array of properties.
Exceptions
ExceptionCondition
ArgumentException The input value is invalid for this AssetPropertyList property.
ArgumentNullException A non-optional argument was null
InvalidOperationException The asset property is not editable.
Remarks
All the properties in the list are of the same AssetPropertyType. The AssetPropertyType can only be Integer, Double4, Float or Double, Enumeration.
See Also