ScheduleDefinitionSetFieldOrder Method

Reorders the fields in the schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetFieldOrder(
	IList<ScheduleFieldId> fieldIds
)

Parameters

fieldIds  IListScheduleFieldId
The field IDs in a new order.
Exceptions
ExceptionCondition
ArgumentException fieldIds does not contain exactly the same field IDs as this ScheduleDefinition currently contains.
ArgumentNullException A non-optional argument was null
See Also