AnalysisDisplayColorSettingsSetIntermediateColors Method |
Set intermediate color entries (other than the minimum and maximum settings).
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetIntermediateColors(
IList<AnalysisDisplayColorEntry> map
)
Public Sub SetIntermediateColors (
map As IList(Of AnalysisDisplayColorEntry)
)
public:
void SetIntermediateColors(
IList<AnalysisDisplayColorEntry^>^ map
)
member SetIntermediateColors :
map : IList<AnalysisDisplayColorEntry> -> unit
Parameters
- map IListAnalysisDisplayColorEntry
-
Array of intermediate color entries.
ExceptionsException | Condition |
---|
ArgumentException |
intermediate color entries with specific values are not ordered by value (min to max) or too many intermediate colors (>100).
|
ArgumentNullException |
A non-optional argument was null
|
See Also