WorksetConfigurationOpen Method |
Sets a group of user-created worksets to open.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void Open(
IList<WorksetId> worksetsToOpen
)
Public Sub Open (
worksetsToOpen As IList(Of WorksetId)
)
public:
void Open(
IList<WorksetId^>^ worksetsToOpen
)
member Open :
worksetsToOpen : IList<WorksetId> -> unit
Parameters
- worksetsToOpen IListWorksetId
-
The group of user-created worksets to open. Non-user-created worksets and invalid workset ids will be ignored.
Exceptions
Remarks
Calling this method on a configuration created with options other than WorksetConfigurationOption.OpenAllWorksets will set these
worksets to be explicitly opened. If all worksets are set to open, the configuration will be unchanged. Worksets other than the inputs are unaffected.
See Also