StructuralFramingUtilsDisallowJoinAtEnd Method |
Sets the indicated end of the framing element to not be allowed to join to others.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static void DisallowJoinAtEnd(
FamilyInstance familyInstance,
int end
)
Public Shared Sub DisallowJoinAtEnd (
familyInstance As FamilyInstance,
end As Integer
)
public:
static void DisallowJoinAtEnd(
FamilyInstance^ familyInstance,
int end
)
static member DisallowJoinAtEnd :
familyInstance : FamilyInstance *
end : int -> unit
Parameters
- familyInstance FamilyInstance
-
The FamilyInstance, which must be of a structural framing category.
- end Int32
-
The index of the end (0 for the start, 1 for the end).
Exceptions
Remarks
If this framing element is already joined at this end, it will become disconnected.
See Also