FillPattern(String, FillPatternTarget, FillPatternHostOrientation, Double, Double, Double) Constructor

Creates a simple crosshatch fill pattern based on the given name, angle, spacing, FillPatternTarget and FillPatternHostOrientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FillPattern(
	string name,
	FillPatternTarget target,
	FillPatternHostOrientation orientation,
	double angle,
	double spacing1,
	double spacing2
)

Parameters

name  String
The name.
target  FillPatternTarget
The fill pattern target.
orientation  FillPatternHostOrientation
The fill pattern orientation.
angle  Double
The angle.
spacing1  Double
The spacing.
spacing2  Double
The spacing.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also