SpatialElementGeometryCalculatorCalculateSpatialElementGeometry Method |
Compute the spatial element geometry and returns the boundary face information.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic SpatialElementGeometryResults CalculateSpatialElementGeometry(
SpatialElement spatialElement
)
Public Function CalculateSpatialElementGeometry (
spatialElement As SpatialElement
) As SpatialElementGeometryResults
public:
SpatialElementGeometryResults^ CalculateSpatialElementGeometry(
SpatialElement^ spatialElement
)
member CalculateSpatialElementGeometry :
spatialElement : SpatialElement -> SpatialElementGeometryResults
Parameters
- spatialElement SpatialElement
-
Specifies the spatial element needs to be computed, should be Room or Space.
Return Value
SpatialElementGeometryResults
Requested boundary face information.
ExceptionsException | Condition |
---|
ArgumentException |
spatialElement is not a room or a space, and thus has no 3D geometry to calculate.
-or-
spatialElement is not enclosed in 2d or has no location, or the height is too small, and thus has no 3D geometry to calculate.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
Failed to compute the given spatial element's geometry.
|
See Also