ExportIFCCategoryInfo(Boolean, String, String, String, String) Constructor |
Constructs a new ExportIFCCategoryInfo with input values.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ExportIFCCategoryInfo(
bool ifcExportFlag,
string ifcEntityName,
string ifcPredefinedType,
string ifcUserDefinedType,
string ifcPresentationLayerName
)
Public Sub New (
ifcExportFlag As Boolean,
ifcEntityName As String,
ifcPredefinedType As String,
ifcUserDefinedType As String,
ifcPresentationLayerName As String
)
public:
ExportIFCCategoryInfo(
bool ifcExportFlag,
String^ ifcEntityName,
String^ ifcPredefinedType,
String^ ifcUserDefinedType,
String^ ifcPresentationLayerName
)
new :
ifcExportFlag : bool *
ifcEntityName : string *
ifcPredefinedType : string *
ifcUserDefinedType : string *
ifcPresentationLayerName : string -> ExportIFCCategoryInfo
Parameters
- ifcExportFlag Boolean
-
The flag that indicates whether the category is exported.
- ifcEntityName String
-
The IFC entity name.
- ifcPredefinedType String
-
The IFC predefined type.
- ifcUserDefinedType String
-
The IFC user defined type.
- ifcPresentationLayerName String
-
The IFC presentation layer name.
Exceptions
See Also