ViewShapeBuilderValidateShape Method |
Validates a shape represented as a collection of geometry objects for use as a view-specific shape.
The objects are expected to be either points, curves or polylines.
Curves are expected to be flat and lie in a plane perpendicular to view normal as defined by view type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool ValidateShape(
IList<GeometryObject> shape,
DirectShapeTargetViewType targetViewType
)
Public Shared Function ValidateShape (
shape As IList(Of GeometryObject),
targetViewType As DirectShapeTargetViewType
) As Boolean
public:
static bool ValidateShape(
IList<GeometryObject^>^ shape,
DirectShapeTargetViewType targetViewType
)
static member ValidateShape :
shape : IList<GeometryObject> *
targetViewType : DirectShapeTargetViewType -> bool
Parameters
- shape IListGeometryObject
-
- targetViewType DirectShapeTargetViewType
-
Return Value
Boolean
Returns true if %shape% may be used as a view-specific shape representation, false otherwise.
Exceptions
See Also