ElementMulticlassFilter(IListType) Constructor

Constructs a new instance of a filter to find elements whose Element subclasses matches any of a given set of input classes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementMulticlassFilter(
	IList<Type> typeList
)

Parameters

typeList  IListType
The list of Element subclass types to match.
Exceptions
ExceptionCondition
ArgumentException One or more input types are not valid subclasses of Element for this filter. -or- One or more of the types do not exist in Revit's native object model.
ArgumentNullException A non-optional argument was null
See Also