StructuralFramingUtilsIsEndReferenceValid Method |
Determines if the given reference can be set for the given end of the framing element.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsEndReferenceValid(
FamilyInstance familyInstance,
int end,
Reference pick
)
Public Shared Function IsEndReferenceValid (
familyInstance As FamilyInstance,
end As Integer,
pick As Reference
) As Boolean
public:
static bool IsEndReferenceValid(
FamilyInstance^ familyInstance,
int end,
Reference^ pick
)
static member IsEndReferenceValid :
familyInstance : FamilyInstance *
end : int *
pick : Reference -> bool
Parameters
- familyInstance FamilyInstance
-
The FamilyInstance, which must be of a structural framing category, non-concrete and joined at the given end.
- end Int32
-
The index of the end (0 for the start, 1 for the end).
- pick Reference
-
The reference to be checked against the given end of the framing element.
Return Value
Boolean
True if the given reference can be set for the given end of the framing element.
Exceptions
See Also