DocumentPlanTopologies(Phase) Property |
Gets the PlanTopologies of the current project in a given phase.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic PlanTopologySet this[
Phase phase
] { get; }
Public ReadOnly Property PlanTopologies (
phase As Phase
) As PlanTopologySet
Get
public:
property PlanTopologySet^ PlanTopologies[Phase^ phase] {
PlanTopologySet^ get (Phase^ phase);
}
member PlanTopologies : PlanTopologySet with get
Parameters
- phase Phase
- The phase of the Plan Topology.
Property Value
PlanTopologySet
RemarksAccessing plan topologies requires that document is modifiable as it will actually trigger calculating plan topologies if they have not been calculated yet.
The time necessary for the calculations may be significant and should be considered.
See Also