MeshFromGeometryOperationIssue Enumeration |
Issues encountered while constructing meshes as fallbacks
for geometrical operations.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum MeshFromGeometryOperationIssue
Public Enumeration MeshFromGeometryOperationIssue
public enum class MeshFromGeometryOperationIssue
type MeshFromGeometryOperationIssue
MembersMember name | Value | Description |
---|
AllFine | 0 |
No issues were encountered. Issues of this type should not
be present in MeshFromGeometryOperationResult.
|
NoUsableCurveLoopsInInput | 1 |
While one or more curve loops were expected as one of the input
parameters while building a mesh, no loops containing curves were
provided.
|
MissingCurveLoopsInInput | 2 |
While several curve loops were expected as one of the input
parameters while building a mesh, some of them were not provided.
|
EmptyCurveLoopsInInput | 3 |
Among curve loops expected as input parameters while building
a mesh, some are empty.
|
CurveLoopsWithoutCurvesInInput | 4 |
Among curve loops expected as input parameters while building
a mesh, some are not empty, but do not have any curves.
|
NonPlanarProfileLoop | 5 |
Among curve loops expected as input parameters while building
a mesh, some are not planar.
|
InputCurveLoopProblemWithFallback | 6 |
An unidentified problem with an input curve loop. A fallback
is attempted.
|
InputCurveLoopWrongOpenFlag | 7 |
An input curve has incorrect open flag.
|
NonContinuousInputCurveLoop | 8 |
A non-continuous input curve loop. Either wrong curve flips
or genuine gaps.
|
MissingCurvesInInputLoop | 9 |
An input curve loop has missing curves.
|
InternalUtilityError | 10 |
An internal Revit problem. Issues of this type should not
normally be present in MeshFromGeometryOperationResult.
Please notify Autodesk support if encountered.
|
InternalMissingError | 11 |
An internal Revit problem. Issues of this type should not be
present in TessellatedShapeBuilderResult. Please notify
Autodesk support if encountered.
|
InternalError | 12 |
An internal Revit problem. Issues of this type should not
normally be present in MeshFromGeometryOperationResult.
Please notify Autodesk support if encountered.
|
NotSetYet | 13 |
An issue has not been set yet.
|
NumberOfIssueTypes | 14 |
Not a code of some issue, but the number of known types of issues.
Issues of this type should not be
present in TessellatedShapeBuilderResult. Please notify
Autodesk support if encountered
|
See Also