CriticalPathCollector Constructor |
Creates a new CriticalPathCollector that visits the analytical segments on the network critical path.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic CriticalPathCollector(
Document doc,
MEPNetworkSegmentId segmentId
)
Public Sub New (
doc As Document,
segmentId As MEPNetworkSegmentId
)
public:
CriticalPathCollector(
Document^ doc,
MEPNetworkSegmentId^ segmentId
)
new :
doc : Document *
segmentId : MEPNetworkSegmentId -> CriticalPathCollector
Parameters
- doc Document
-
The document of the analytical network.
- segmentId MEPNetworkSegmentId
-
The analytical segment to identify the network. Note that this segment is not required to be on the critical path.
Exceptions
See Also