ReferenceIntersectorFind Method |
Projects a ray from the origin along the given direction, and returns all references from intersected elements which match the ReferenceIntersector's criteria.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<ReferenceWithContext> Find(
XYZ origin,
XYZ direction
)
Public Function Find (
origin As XYZ,
direction As XYZ
) As IList(Of ReferenceWithContext)
public:
IList<ReferenceWithContext^>^ Find(
XYZ^ origin,
XYZ^ direction
)
member Find :
origin : XYZ *
direction : XYZ -> IList<ReferenceWithContext>
Parameters
- origin XYZ
-
The origin of the ray.
- direction XYZ
-
The direction of the ray.
Return Value
IListReferenceWithContext
A collection containing the intersected references.
Exceptions
See Also