ExternalResourceBrowserDataAddSubFolder(String, String) Method |
Adds a subfolder to the folder path with the given name and icon type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void AddSubFolder(
string folderName,
string iconPath
)
Public Sub AddSubFolder (
folderName As String,
iconPath As String
)
public:
void AddSubFolder(
String^ folderName,
String^ iconPath
)
member AddSubFolder :
folderName : string *
iconPath : string -> unit
Parameters
- folderName String
-
The name of the folder.
- iconPath String
-
Icon path.
ExceptionsException | Condition |
---|
ArgumentException |
The folderName is not a valid folder name used to display in Revit external resource browse UI.
The name should be a unique non-empty short name and it should not contain any invalid character of \\/:*?"<>|.
The length of combined path(server name + folder path) should not exceeds 259.
|
ArgumentNullException |
A non-optional argument was null
|
See Also