ScheduleSheetInstanceSegmentIndex Property |
The schedule segment index of this ScheduleSheetInstance.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic int SegmentIndex { get; set; }
Public Property SegmentIndex As Integer
Get
Set
public:
property int SegmentIndex {
int get ();
void set (int value);
}
member SegmentIndex : int with get, set
Property Value
Int32
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: segmentIndex is not a valid segment index.
|
InvalidOperationException |
When setting this property: The schedule of this ScheduleSheetInstance is a titleblock revision schedule or a sheet specific schedule.
|
Remarks
This property represents which schedule segment is referred to by this ScheduleSheetInstance. It normally starts with 0 and
is less than the total number of the schedule segments, but there're some speccial cases:
- The segment index value could be -1, which means referring to the whole schedule but not a specific segment.
- The segment index value 0 should be considered the same as -1 if the referenced schedule is not split in normal cases.
- The segment index value must be 0 if the schedule is a revision schedule and in a family.
- The segment index value can't be modified if the schedule is filter by sheet. (In fact, The segment
is referenced to is belongs to an internal schedule that only valid in the current view in this case.)
See Also