PushButtonData Constructor

Constructs a new instance of PushButtonData.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public PushButtonData(
	string name,
	string text,
	string assemblyName,
	string className
)

Parameters

name  String
The internal name of the new button.
text  String
The user visible text seen on the new button.
assemblyName  String
The assembly path of the button.
className  String
The name of the class containing the implementation for the command.
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when is passed for one or more arguments.
ArgumentExceptionThrown when an empty string is passed for one or more arguments.
See Also