IDirectContext3DServerGetBoundingBox Method |
Reports a bounding box of the geometry that this server submits for drawing.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
SyntaxOutline GetBoundingBox(
View dBView
)
Function GetBoundingBox (
dBView As View
) As Outline
Outline^ GetBoundingBox(
View^ dBView
)
abstract GetBoundingBox :
dBView : View -> Outline
Parameters
- dBView View
-
The view where rendering will occur. If this argument is , a view-independent bounding box should be reported.
Return Value
Outline
The bounding box as an Outline.
RemarksRevit uses the bounding box when navigating views, e.g., when a Zoom to Fit command is issued.
The reported bounding box does not have to be tight. However, there may be unintended side-effects
if the box is inconsistent with the submitted geometry.
See Also