FamilySymbolIsActive Property |
Identifies whether the symbol is active.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsActive { get; }
Public ReadOnly Property IsActive As Boolean
Get
public:
property bool IsActive {
bool get ();
}
member IsActive : bool with get
Property Value
Boolean
Remarks
Symbols that are not used in the document may be deactivated to conserve memory and regeneration time.
When the symbol is inactive, its geometry is empty and cannot be accessed.
In order to access the geometry of a symbol that is not active in the document,
the symbol should first be activated by calling
Activate.
See Also