ViewShapeBuilderValidateViewType Method |
Validates the incoming view type. As of today, the only allowed view type is Plan.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool ValidateViewType(
DirectShapeTargetViewType targetViewType
)
Public Shared Function ValidateViewType (
targetViewType As DirectShapeTargetViewType
) As Boolean
public:
static bool ValidateViewType(
DirectShapeTargetViewType targetViewType
)
static member ValidateViewType :
targetViewType : DirectShapeTargetViewType -> bool
Parameters
- targetViewType DirectShapeTargetViewType
-
Return Value
Boolean
True if %targetViewType% is DirectShapeTargetViewType::Plan
Exceptions
See Also