CompoundStructureGetRegionsAssociatedToLayer Method |
Gets the set of region ids associated to a particular layer.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<int> GetRegionsAssociatedToLayer(
int layerIdx
)
Public Function GetRegionsAssociatedToLayer (
layerIdx As Integer
) As IList(Of Integer)
public:
IList<int>^ GetRegionsAssociatedToLayer(
int layerIdx
)
member GetRegionsAssociatedToLayer :
layerIdx : int -> IList<int>
Parameters
- layerIdx Int32
-
The index of a layer in this CompoundStructure.
Return Value
IListInt32
An array of region ids which are associated to the specified layer.
Exceptions
Remarks
Regions are associated to layers. In a vertically compound structure, more than one region may be associated to a
single layer.
See Also