TransferredProjectStandardsEventArgsGetSelectedExternalItems Method |
Gets the collection of externally added items that the user opted to enable for transfer in the Transfer Project Standards dialog.
Namespace: Autodesk.Revit.UI.EventsAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IDictionary<Guid, string> GetSelectedExternalItems()
Public Function GetSelectedExternalItems As IDictionary(Of Guid, String)
public:
IDictionary<Guid, String^>^ GetSelectedExternalItems()
member GetSelectedExternalItems : unit -> IDictionary<Guid, string>
Return Value
IDictionaryGuid,
String
External items user wants to transfer.
Remarks
If more than one add-in has registered external items, this will report items enabled for transfer for all such add-ins. Add-ins should handle the transfer only for those items which they actually registered in the TransferringProjectStandards event.
See Also