CircuitNamingSchemeIsValidCombinedParameters Method |
Validates whether the combined parameters is valid.
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsValidCombinedParameters(
Document aDocument,
IList<TableCellCombinedParameterData> data
)
Public Shared Function IsValidCombinedParameters (
aDocument As Document,
data As IList(Of TableCellCombinedParameterData)
) As Boolean
public:
static bool IsValidCombinedParameters(
Document^ aDocument,
IList<TableCellCombinedParameterData^>^ data
)
static member IsValidCombinedParameters :
aDocument : Document *
data : IList<TableCellCombinedParameterData> -> bool
Parameters
- aDocument Document
-
The document.
- data IListTableCellCombinedParameterData
-
The array of TableCellCombinedParameterData to be set as combined parameters.
Return Value
Boolean
Returns true if the combined parameters are valid, and false otherwise.
Exceptions
RemarksCurrently the following parameters are supported:
- Shared Parameters
- RBS_ELEC_CIRCUIT_NAME
- RBS_ELEC_CIRCUIT_PANEL_PARAM
- RBS_ELEC_CIRCUIT_TYPE
- CIRCUIT_LOAD_CLASSIFICATION_ABBREVIATION_PARAM
- RBS_ELEC_CIRCUIT_NAMING_INDEX
- RBS_ELEC_NUMBER_OF_POLES
- RBS_ELEC_CIRCUIT_RATING_PARAM
- RBS_ELEC_CIRCUIT_FRAME_PARAM
- RBS_ELEC_VOLTAGE
- CIRCUIT_PHASE_PARAM
- CIRCUIT_WAYS_PARAM
- RBS_ELEC_CIRCUIT_SLOT_INDEX
See Also