FailureHandlingOptionsSetTransactionFinalizer Method

Sets the callback to be executed after the transaction is completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FailureHandlingOptions SetTransactionFinalizer(
	ITransactionFinalizer finalizer
)

Parameters

finalizer  ITransactionFinalizer
The callback to be executed after the transaction is completed.

Return Value

FailureHandlingOptions
This FailureHandlingOptions object.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also