RepeaterBoundsAreCoordinatesInBounds Method |
Determines whether given coordinates are within the bounds.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool AreCoordinatesInBounds(
RepeaterCoordinates coordinates,
bool treatCyclicalBoundsAsInfinite
)
Public Function AreCoordinatesInBounds (
coordinates As RepeaterCoordinates,
treatCyclicalBoundsAsInfinite As Boolean
) As Boolean
public:
bool AreCoordinatesInBounds(
RepeaterCoordinates^ coordinates,
bool treatCyclicalBoundsAsInfinite
)
member AreCoordinatesInBounds :
coordinates : RepeaterCoordinates *
treatCyclicalBoundsAsInfinite : bool -> bool
Parameters
- coordinates RepeaterCoordinates
-
The coordinates.
- treatCyclicalBoundsAsInfinite Boolean
-
True if cyclical directions should be treated as unbounded.
Return Value
Boolean
True if the coordinates are within the bounds.
Exceptions
Remarks
The coordinates must have the same number of dimensions as the bounds.
This method does not apply to zero dimensional bounds.
See Also