CompoundStructureGetWidth(Int32) Method

Computes the width of the envelope (2d bounding box) of the specified region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double GetWidth(
	int regionId
)

Parameters

regionId  Int32
The id of a region in this vertically compound structure.

Return Value

Double
The width of the envelope (2d bounding box) of the region.
Exceptions
ExceptionCondition
ArgumentException It is not a valid region id.
InvalidOperationException This operation is valid only for vertically compound structures.
See Also