FilterNumericRuleEvaluatorEvaluate(Int32, Int32) Method |
Note: This API is now obsolete.
Derived classes should override this method to implement the desired test.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax[ObsoleteAttribute("This method is deprecated in Revit 2024. Override the evalute method taking Int64 instead. It may be removed in a future version.")]
public bool Evaluate(
int lhs,
int rhs
)
<ObsoleteAttribute("This method is deprecated in Revit 2024. Override the evalute method taking Int64 instead. It may be removed in a future version.")>
Public Function Evaluate (
lhs As Integer,
rhs As Integer
) As Boolean
public:
[ObsoleteAttribute(L"This method is deprecated in Revit 2024. Override the evalute method taking Int64 instead. It may be removed in a future version.")]
bool Evaluate(
int lhs,
int rhs
)
[<ObsoleteAttribute("This method is deprecated in Revit 2024. Override the evalute method taking Int64 instead. It may be removed in a future version.")>]
member Evaluate :
lhs : int *
rhs : int -> bool
Parameters
- lhs Int32
-
A value from an element in the document.
- rhs Int32
-
The user-supplied value against which values from the document are tested.
Return Value
Boolean
True if
lhs,
rhs satisfy the condition implemented by this evaluator.
See Also