DocumentGetRoomAtPoint(XYZ) Method |
Gets a room containing the point.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Room GetRoomAtPoint(
XYZ point
)
Public Function GetRoomAtPoint (
point As XYZ
) As Room
public:
Room^ GetRoomAtPoint(
XYZ^ point
)
member GetRoomAtPoint :
point : XYZ -> Room
Parameters
- point XYZ
- Point to be checked.
Return Value
RoomThe room containing the point.
Exceptions
RemarksSurveys only the rooms from the final phase of the project. The first one found will be returned. If there is no room containing the point, it returns .
See Also