RebarUpdateCurvesDataGetCycleCounter Method |
Gets the cycle counter that is stored in the rebar.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic int GetCycleCounter()
Public Function GetCycleCounter As Integer
public:
int GetCycleCounter()
member GetCycleCounter : unit -> int
Return Value
Int32
Returns the cycle counter.
Remarks
The cycle counter value is changed when the free form Rebar element is selected and the user press Space key
-or- by through [!:Autodesk::Revit::DB::Structure::RebarRebarFreeFormAccessor::CycleCounter] property.
-or- by the server if it considers that the counter reaches the maximum value and reset it (set it to 0).
See Also