MEPAnalyticalSegment Class

Represents an analytical segment of the MEP analytical model.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.AnalysisMEPAnalyticalSegment

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class MEPAnalyticalSegment : IDisposable

The MEPAnalyticalSegment type exposes the following members.

Properties
 NameDescription
Public propertyArea The area of the segment profile.
Public propertyDemandFlow The designed flow value, in ft^3/s.
Public propertyDomainType The connector domain type of this segment.
Public propertyEndNode The id of the end analytical node.
Public propertyId The identity of this segment.
Public propertyInnerDiameter The inner diameter of this segment, in ft. For rectangular or oval profile, this may be the hydraulic diameter.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyRevitElementId The id of the owning Revit element.
Public propertyRoughness The roughness of this segment, in ft.
Public propertySegmentType The analytical segment type.
Public propertyStartNode The id of the start analytical node.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the MEPAnalyticalSegment
Public methodGetNetworkSegmentId Gets the NetworkSegmentId.
Top
See Also