CompoundStructureDeleteLayer Method |
Deletes the specified layer from this CompoundStructure.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool DeleteLayer(
int layerIdx
)
Public Function DeleteLayer (
layerIdx As Integer
) As Boolean
public:
bool DeleteLayer(
int layerIdx
)
member DeleteLayer :
layerIdx : int -> bool
Parameters
- layerIdx Int32
-
The layer index is zero based. It counts from the exterior of wall and from the top of roofs, floors and ceilings.
Return Value
Boolean
True if the layer was successfully deleted, and false otherwise.
Exceptions
Remarks
For a vertically compound structure, a layer
may only be deleted if it is not associated to a region, or else it is associated to exactly one simple
region, which will also be deleted. Regions associated to layers with index greater than layerIdx will
have their associated layer indices decremented by one.
See Also