IDirectContext3DServerCanExecute Method |
Can be used to allow the server to execute only in certain views.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxbool CanExecute(
View dBView
)
Function CanExecute (
dBView As View
) As Boolean
bool CanExecute(
View^ dBView
)
abstract CanExecute :
dBView : View -> bool
Parameters
- dBView View
-
The view where rendering will occur.
Return Value
Boolean
True if the server can be executed in the provided view, false otherwise.
RemarksExecution of a DirectContext3D server means that the server is called upon to contribute a bounding box
and graphics content (opaque and transparent) for an opened view. The following are some of the conditions
that control whether the server is executed:
- The return value of this interface method.
- Whether the server is one of the active servers for the service.
- For servers that use DirectContext3D handles, the visibility of handle instances.
See Also