The dot product of this vector and the specified vector.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double DotProduct(
XYZ source
)
Public Function DotProduct (
source As XYZ
) As Double
public:
double DotProduct(
XYZ^ source
)
member DotProduct :
source : XYZ -> float
Parameters
- source XYZ
- The vector to multiply with this vector.
Return Value
DoubleThe real number equal to the dot product.
Exceptions
Remarks
The dot product is the sum of the respective coordinates of the two vectors:
Vx*Wx + Vy*Wy + Vz*Wz. Also known as scalar product or inner product.
See Also