SpatialElementFromToCalculationPointsMakeToPositionAcceptable Method |
This function takes a potential "to" point and converts it to be a similar point on the opposite side of the family's host from
the "from" point if necessary.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic XYZ MakeToPositionAcceptable(
XYZ newToLocation
)
Public Function MakeToPositionAcceptable (
newToLocation As XYZ
) As XYZ
public:
XYZ^ MakeToPositionAcceptable(
XYZ^ newToLocation
)
member MakeToPositionAcceptable :
newToLocation : XYZ -> XYZ
Parameters
- newToLocation XYZ
-
The desired "to" location
Return Value
XYZ
The valid "to" location.
Exceptions
Remarks
If the point is already an acceptable "to" location then the original point will be returned. Otherwise, the point's
X and Y will be projected onto the centerline of the family's host.
See Also