BRepBuilderPersistentIdsIsValidExternalGeometryIdForNewCorrespondence Method |
Validates the input ExternalGeometryId that will be used to create a correspondence.
In order to be valid, a correspondence for the input ExternalGeometryId must not already exist.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsValidExternalGeometryIdForNewCorrespondence(
ExternalGeometryId externalGeometryId
)
Public Function IsValidExternalGeometryIdForNewCorrespondence (
externalGeometryId As ExternalGeometryId
) As Boolean
public:
bool IsValidExternalGeometryIdForNewCorrespondence(
ExternalGeometryId^ externalGeometryId
)
member IsValidExternalGeometryIdForNewCorrespondence :
externalGeometryId : ExternalGeometryId -> bool
Parameters
- externalGeometryId ExternalGeometryId
-
The ExternalGeometryId to be used in a new correspondence.
Return Value
Boolean
True if the input ExternalGeometryId can be used to create a new correspondence.
Exceptions
See Also