RebarInSystemGetBarPositionTransform Method |
Return a transform representing the relative position of any
individual bar in the set.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Transform GetBarPositionTransform(
int barPositionIndex
)
Public Function GetBarPositionTransform (
barPositionIndex As Integer
) As Transform
public:
Transform^ GetBarPositionTransform(
int barPositionIndex
)
member GetBarPositionTransform :
barPositionIndex : int -> Transform
Parameters
- barPositionIndex Int32
-
An index between 0 and (NumberOfBarPositions-1).
Return Value
Transform
The position of a bar in the set relative to the first position.
Exceptions
Remarks
The transform is a translation along the distribution path.
It can be applied to the results of GetCenterlineCurves() to
produce any bar in the rebar set. For barPositionIndex=0,
the identity transform is always returned.
See Also