DirectShapeOptionsReferencingOption Property |
Whether or not the geometry stored in a DirectShape object may be referenced.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic DirectShapeReferencingOption ReferencingOption { get; set; }
Public Property ReferencingOption As DirectShapeReferencingOption
Get
Set
public:
property DirectShapeReferencingOption ReferencingOption {
DirectShapeReferencingOption get ();
void set (DirectShapeReferencingOption value);
}
member ReferencingOption : DirectShapeReferencingOption with get, set
Property Value
DirectShapeReferencingOption
The default value is Referenceable.
ExceptionsException | Condition |
---|
ArgumentOutOfRangeException |
When setting this property: A value passed for an enumeration argument is not a member of that enumeration
|
Remarks
If the geometry is not referenceable, it may not be used for dimensioning, snapping, alignment, or face-hosting.
The element may still be selected by the user for operations which do not reference individual geometry objects.
See Also