EnergyAnalysisDetailModelGetMainEnergyAnalysisDetailModel Method |
Gets the EnergyAnalysisDetailModel in given document.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static EnergyAnalysisDetailModel GetMainEnergyAnalysisDetailModel(
Document document
)
Public Shared Function GetMainEnergyAnalysisDetailModel (
document As Document
) As EnergyAnalysisDetailModel
public:
static EnergyAnalysisDetailModel^ GetMainEnergyAnalysisDetailModel(
Document^ document
)
static member GetMainEnergyAnalysisDetailModel :
document : Document -> EnergyAnalysisDetailModel
Parameters
- document Document
-
The document that contains the physical model of the building.
Return Value
EnergyAnalysisDetailModel
Returns the EnergyAnalysisDetailModel contained in the document, if it exists. If it does not exist, this returns
.
Exceptions
See Also