PanelScheduleTemplateIsValidType(PanelScheduleType) Method |
Checks if given type is valid for this panel schedule template element.
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsValidType(
PanelScheduleType panelScheduleType
)
Public Shared Function IsValidType (
panelScheduleType As PanelScheduleType
) As Boolean
public:
static bool IsValidType(
PanelScheduleType panelScheduleType
)
static member IsValidType :
panelScheduleType : PanelScheduleType -> bool
Parameters
- panelScheduleType PanelScheduleType
-
The given type to check.
Return Value
Boolean
True if panel schedule template can have a type assigned and this type is valid for this element, false otherwise.
Exceptions
Remarks
A type is valid for a panel schedule template element if it is defined by the PanelScheduleType class.
Note: PanelScheduleType::Enum::Unknown is not a valid type, it is used for initializing the variable of
the PanelScheduleType::Enum.
See Also