ExportLayerTableItem Property |
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ExportLayerInfo this[
ExportLayerKey layerKey
] { get; set; }
Public Default Property Item (
layerKey As ExportLayerKey
) As ExportLayerInfo
Get
Set
public:
virtual property ExportLayerInfo^ default[ExportLayerKey^ layerKey] {
ExportLayerInfo^ get (ExportLayerKey^ layerKey) sealed;
void set (ExportLayerKey^ layerKey, ExportLayerInfo^ value) sealed;
}
abstract Item : ExportLayerInfo with get, set
override Item : ExportLayerInfo with get, set
Parameters
- layerKey ExportLayerKey
-
Return Value
ExportLayerInfo
A copy of the
ExportLayerInfo for the layer Key.
ExceptionsException | Condition |
---|
ArgumentException |
When getting this property:
An entry with the given key is not present in the table.
|
Remarks
When getting this property, it returns a copy of the
ExportLayerInfo from the table. In order to
make changes to the
ExportLayerInfo and use those settings during export, set the modified
ExportLayerInfo back into the table using the same key.
See Also