BoundingBoxIntersectsFilter(Outline, Boolean) Constructor |
Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline,
with the option to invert the filter and match all elements with a bounding box that are not intersecting the given Outline.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic BoundingBoxIntersectsFilter(
Outline outline,
bool inverted
)
Public Sub New (
outline As Outline,
inverted As Boolean
)
public:
BoundingBoxIntersectsFilter(
Outline^ outline,
bool inverted
)
new :
outline : Outline *
inverted : bool -> BoundingBoxIntersectsFilter
Parameters
- outline Outline
-
The Outline used to find elements with a bounding box that intersect it.
- inverted Boolean
-
True if the filter should be inverted and match all elements with a bounding box that are not intersecting the given Outline.
Exceptions
See Also